Fixing installer for SnowLeopard 64Bits

 

ranmanh's picture

Hi,

the Application fails to instal for SnowLeopard 64 Bits.
You get a "Couldn't raise admin privileges"

To fix it modify the following from your terminal:

xTuple-3.4.0-osx-x86-installer.app/Contents/MacOS/installbuilder.sh

#!/bin/sh
os_version=`uname -r`
machine_platform=`uname -p`
if [ "${os_version:0:1}" == "6" ];then
executable="osx-10.2"
elif [ "${machine_platform}" == "i386" ];then
executable="osx-intel"
else
executable="osx-ppc"
fi
if [[ "${1}1" == --help ]];then
"`dirname \"${0}\"`/$executable" "$@"
else
"`dirname \"${0}\"`/xTuple ERP" $executable "$@"
fi
sh-3.2#

As:

#!/bin/sh
os_version=`uname -r`
machine_platform=`uname -p`
if [ "${os_version:0:1}" == "6" ];then
executable="osx-10.2"
elif [ "${machine_platform}" == "x86_64" ];then
executable="osx-intel"
else
executable="osx-ppc"
fi
if [[ "${1}1" == --help ]];then
"`dirname \"${0}\"`/$executable" "$@"
else
"`dirname \"${0}\"`/xTuple ERP" $executable "$@"
fi
sh-3.2#

Just replace the i386 by x86_64.
To know the architecture run on your system just type:
uname -m
x86_64

Thanks