Upgrade from Postbooks3.7.0/Postgres8.4.0/MacOS10.7.5 to MacOS10.10.5?

 

dmacune's picture

It might be time to update our MacOS from 10.7.5 to 10.10.5 on our Mac MiniServer.  Do I need to update Postbooks 3.7.0 & Postgres 8.4.0 also?  If so, is Xtuple Updater the right tool for this?  Do I want the latest versions of Postbooks & Postgres?  Any shared advice or experience will be appreciated.  

 
brody
brody's picture
Offline
Joined: 06/01/2006
I would recommend clean

I would recommend clean installing a new OS and new Postgres on a second hard drive.  You would then need only migrate your DB out of 8.4.0 and into the new Postgres.  Then once completed this new hard drive is swapped in to be your new boot drive.  This would leave your current production setup functional and running up until the switchover.  I recommend you upgrade to a SSD drive for this as well, it will speed up that Mini.  (i did)

 

make backups

 

or something like that.