Migrated to Cloud. Now getting beachballs.

 

roberthammen's picture

Hi folks,

One of my clients moved from running xTuple on a local OS X Lion server to a cloud-based instance. They also increased their Internet bandwidth at the same time.

They are seeing really poor performance. Lot of beachballs when working. Their 50 Mbit down, 10 Mbit up connection is NOT saturated when this happens. Clients are all Macs, running either 10.8.5 or 10.9.4 (soon 10.9.5).

Any things to check/tweak on the application side? Do not know what version of xTuple they are running, but since they just switched to a cloud version in the last couple of months, assume it's something recent.

Any troubleshooting tips to suggest are appreciated.

Thanks,

--Robert

 
ricambiamerica
ricambiamerica's picture
Offline
Joined: 06/16/2013
During our initial

During our initial implementation, we saw the same thing (we use the Rackspace Cloud, and connect on Macs).    The solution -- and our system now seriously hauls -- was to switch to a different data center geographically closer to our location with fewer hops and less latency across the 'net.    In our case, we moved our Postgres from Rackspace DFW to IAD, and it made a massive difference in usability.    We are located in North Carolina.   Our failover server is also a Rackspace cloud instance located in ORD. 

We are on  xTuple 4.7 (and Yosemite) now, and have had the best year in the history of the company, in many ways thanks to our xTuple implementation.