Bug Tracker Incident #8486

 


Summary
Project
INCDT - xTuple ERP
Incident Category
Bugs
Incident Number
8486
Visibility
public


Product Version
3.3.0Alpha
Fixed In Version
3.3.0Alpha


Summary
Images list unusuable over slow remote links


Description

The master list of images is unusable over slow network links.

This is caused by the list loading all image data from the database even though nothing is done with this in the images class.

Patch attached.


Details
Reporter
petebisson
CRM Account
xTincident Default Account
Status
Closed
Assigned
cryan


Priority
Normal
Severity
Patch
Updated
09-06-12 15:39
Resolution
Fixed



Comments

DateUsernameComment
03/04/11 08:25mfgadmin

Additional Info:

Relates to 'Problems with Remote Connection/Access'
http://www.xtuple.org/phpBB2/viewtopic.php?p=17856#17856

03/04/11 08:25mfgadmin

The master list of images is unusable over slow network links.

This is caused by the list loading all image data from the database even though nothing is done with this in the images class.

Patch attached.

08/18/09 13:36gmoskowitz

verified by code inspection and by running the images window to ensure the size column displays and the image child window opens properly.

05/15/09 14:40svn

Revision: 5829
http://postbooks.svn.sourceforge.net/postbooks/?rev=5829&view=rev
Author: cryan
Date: 2009-05-15 18:39:48 +0000 (Fri, 15 May 2009)

Log Message:
-----------
Incorporated patch submission issue #8486.

Modified Paths:
--------------
xtuple/trunk/guiclient/images.cpp

02/23/09 09:57petebisson

Added a relationship to #8521 as the images that are stored in the database are sometimes even bigger than they need to be, which makes this issue even worse.

02/16/09 08:59petebisson

Just to clarify, this happens when there is a large amount of data in the images table (either big images or lots of of them) and being accessed over a slow link - for example an encrypted VPN tunnel.

As UUencoding makes the data 135% of the original filesize, it can soon get very large.

Although this will eventually show the data over a slow link, Windows reports the xTuple client as not responding, so users tend to kill the client and try again.



Characteristics

Operating System
 
Doc Flag
False
Copyright Assigned
Yes
HaxTuple
No
Backport
No

Files

Filename
images.excludeData.patch


Related Documents

TypeNumberDescriptionRelationshipRemove
Incident4105Probs w/commission on AR Db/Cr MemosRelated tox
ProjectXTUPLEAPPSPorted From Mantisx


Subscribers

You do not have permission to view subscribers.


Incident History

DateUsernameFieldChange
12/16/10 09:13acdrupalNewIncident Added