Bug Tracker Incident #7317

 


Summary
Project
INCDT - xTuple ERP
Incident Category
Bugs
Incident Number
7317
Visibility
public


Product Version
3.0.1
Fixed In Version
None


Summary
Detailed Inventory History by Lot/Serial #


Description

Detailed Inventory History by Lot/Serial # report fails in Multi-Level Trace "forward" mode. Database Log displays error shown in attached text file.
Also, report can show repeated information in "backward" mode.


Details
Reporter
kleedom
CRM Account
Ken Leedom
Status
Closed
Assigned
None


Priority
Normal
Severity
Minor
Updated
09-06-12 15:39
Resolution
Open



Comments

DateUsernameComment
04/05/11 15:16jrogelstad

Closing because this is really old and the reporter is no longer a partner.

04/05/11 09:09reddog

cannot reproduce in 3.7.0RC. setup environment with lot controlled components, received same lot number multiple times, issued to W/O. forward and backward traces in Detailed Inventory History by Lot/Serial work correctly

03/04/11 08:25mfgadmin

Additional Info:

Key tables involved appear to be ls and ls_detail. The double-receipt-same-lot causes multiple ls_detail records each refering to a single ls record. Also, the failure appears to involve the function, lshist.

03/04/11 08:25mfgadmin

Detailed Inventory History by Lot/Serial # report fails in Multi-Level Trace "forward" mode. Database Log displays error shown in attached text file.
Also, report can show repeated information in "backward" mode.

03/04/11 08:25mfgadmin

Steps to Reproduce:

Failure problem appears to be isolated to circumstances where the report's forward "trace" encounters a Lot Controlled component where multiple receipts of the component were assigned to the same Lot Number. A simple BOM was created where all items were lot controlled. All components were received, however, one of the components was received twice using the same Lot Number. A work order was created and completed for the parent item, components issued, etc. Forward tracing from any component causes the report to fail.

A complete "backward" trace from the parent of the above example showed repeated detail of "sub-components" when the double-receipt-same-lot was tested on a sub-assembly component.

09/04/08 18:57jrogelstad

Mike, did you mean to confirm this? It looks like that''s what your note implies.

09/04/08 15:06matherton

In the demo DB on 3.1beta2 received YPAINT1 in twice with the same lot number against the same PO.

Then completed an STRUCK1 against a work order.

Ran Detail Inventory History by Lot/Serial# for YPAINT1 on the lot that was received twice and selected Forward (and Backward) tracing.

Data displayed with a DB log error.



Characteristics

Backport
No
Operating System
ALL
Doc Flag
False
Copyright Assigned
Yes

Files

Filename
lot trace report error log.txt


Related Documents

TypeNumberDescriptionRelationshipRemove
Incident3720error posting misc po voucherRelated tox
ProjectXTUPLEAPPSPorted From Mantisx


Subscribers

You do not have permission to view subscribers.


Incident History

DateUsernameFieldChange
12/16/10 09:12acdrupalNewIncident Added
04/05/11 09:10reddogDescription Updated: "Detailed Inventory H..." -> "Detailed Inventory H..."
04/05/11 09:10reddogStatusStatus Changed: Confirmed -> Feedback
04/05/11 15:16jrogelstadStatusStatus Changed: Feedback -> Closed