Bug Tracker Incident #15642

 


Summary
Project
INCDT - xTuple ERP
Incident Category
Bugs
Incident Number
15642
Visibility
public


Product Version
3.8.0Alpha
Fixed In Version
3.8.0Beta2


Summary
*Unable to edit and save a Quote item


Description

DB log error is generated on selecting to edit and save a Quote item

Steps to Reproduce:
1. Create a Quote for a customer 'TTOYS' and item 'YTRUCK1'
2. Open the created Quote in edit mode and navigate to line items tab
3. Double click on the line item to open and click on ‘Save’ button on the populated ‘Quote Item’ screen
4. Observe that an error message is displayed and a DB log error is generated

DB log error:
Mon 12. Sep 18:12:10 2011 ERROR: insert or update on table "quitem" violates foreign key constraint "quitem_quitem_itemsrc_id_fkey"
DETAIL: Key (quitem_itemsrc_id)=(3) is not present in table "itemsrc".
QPSQL: Unable to create query
UPDATE quitem SET quitem_scheddate='2011-09-13', quitem_promdate=NULL, quitem_qtyord=100, quitem_qty_uom_id=4, quitem_qty_invuomratio=1, quitem_price=9.5, quitem_price_uom_id=4, quitem_price_invuomratio=1, quitem_memo='', quitem_createorder=TRUE, quitem_order_warehous_id=35, quitem_prcost=0, quitem_taxtype_id=2, quitem_dropship=FALSE, quitem_itemsrc_id=3 WHERE (quitem_id=121);


Details
Reporter
vinaysingu
CRM Account
ZenQ
Status
Closed
Assigned
reddog


Priority
Very High
Severity
Block
Updated
11-22-11 12:00
Resolution
Fixed



Comments

DateUsernameComment
11/22/11 12:00ptyler

Tested okay in 3.8 beta 2 demo db.

09/30/11 12:02reddog

change window salesOrderItem and correctly initialize _itemsrc variable when populating from quote item

09/30/11 12:01svn

Revision: 12553
http://postbooks.svn.sourceforge.net/postbooks/?rev=12553&view=rev
Author: sunsetsolutions
Date: 2011-09-30 16:01:11 +0000 (Fri, 30 Sep 2011)
Log Message:
-----------
Issue #15642:initialize _itemsrc when populating from quitem

Modified Paths:
--------------
xtuple/trunk/guiclient/salesOrderItem.cpp

09/29/11 16:39ptyler

I confirmed this in alpha and I am confirming it again in the beta.

09/15/11 09:03vinaysingu

'Create Purchase Order linked to Sales order' option is not checked in the itemsite of 'YTRUCK1' and no item source is defined for 'YTRUCK1'.
Issue observed with all the items available for selection to create a quote.

09/14/11 16:44reddog

cannot reproduce.

how is the YTRUCK1 Itemsite setup? Is Create Purchase Orders Linked to Sales Orders checked? are there any Item Sources defined for YTRUCK1?

09/12/11 10:25ptyler

Confirmed in 3.8 pre-alpha demo db.

09/12/11 08:41vinaysingu

DB log error is generated on selecting to edit and save a Quote item

Steps to Reproduce:
1. Create a Quote for a customer 'TTOYS' and item 'YTRUCK1'
2. Open the created Quote in edit mode and navigate to line items tab
3. Double click on the line item to open and click on ‘Save’ button on the populated ‘Quote Item’ screen
4. Observe that an error message is displayed and a DB log error is generated

DB log error:
Mon 12. Sep 18:12:10 2011 ERROR: insert or update on table "quitem" violates foreign key constraint "quitem_quitem_itemsrc_id_fkey"
DETAIL: Key (quitem_itemsrc_id)=(3) is not present in table "itemsrc".
QPSQL: Unable to create query
UPDATE quitem SET quitem_scheddate='2011-09-13', quitem_promdate=NULL, quitem_qtyord=100, quitem_qty_uom_id=4, quitem_qty_invuomratio=1, quitem_price=9.5, quitem_price_uom_id=4, quitem_price_invuomratio=1, quitem_memo='', quitem_createorder=TRUE, quitem_order_warehous_id=35, quitem_prcost=0, quitem_taxtype_id=2, quitem_dropship=FALSE, quitem_itemsrc_id=3 WHERE (quitem_id=121);



Characteristics

Operating System
all
HaxTuple
No
Doc Flag
False
Copyright Assigned
Yes
CodeReview
Needed
Backport
No

Files

No Files

Related Documents

TypeNumberDescriptionRelationshipRemove
ProjectXTUPLEAPPSPorted From Mantisx


Subscribers

You do not have permission to view subscribers.


Incident History

DateUsernameFieldChange
11/22/11 12:00ptylerStatusStatus Changed: Resolved -> Closed
09/12/11 08:41vinaysinguNewIncident Added
09/12/11 08:41vinaysinguCharacteristic Backport Added: "No"
09/12/11 08:41vinaysinguCharacteristic CodeReview Added: ""
09/12/11 08:41vinaysinguCharacteristic Operating System Added: "all"
09/12/11 08:41vinaysinguCharacteristic haxTuple Added: "No"
09/12/11 08:41vinaysinguCharacteristic Estimated Hours Added: ""
09/12/11 08:41vinaysinguCharacteristic Doc Flag Added: "False"
09/12/11 08:41vinaysinguCharacteristic Copyright Assigned Added: "Yes"
09/12/11 08:41acdrupalFound In: -> 3.8.0Alpha
09/12/11 08:43vinaysinguDescription Updated: "DB log error is gene..." -> "DB log error is gene..."
09/12/11 10:25ptylerDescription Updated: "DB log error is gene..." -> "DB log error is gene..."
09/12/11 10:25ptylerStatusStatus Changed: New -> Confirmed
09/14/11 16:45reddogStatusStatus Changed: Confirmed -> Feedback
09/15/11 09:03vinaysinguDescription Updated: "DB log error is gene..." -> "DB log error is gene..."
09/15/11 09:03vinaysinguStatusStatus Changed: Feedback -> Assigned
09/29/11 16:31jrogelstadDescription Updated: "DB log error is gene..." -> "DB log error is gene..."
09/29/11 16:31jrogelstadStatusStatus Changed: Assigned -> New
09/29/11 16:39ptylerStatusStatus Changed: New -> Confirmed
09/30/11 07:26jrogelstadPriorityPriority Changed: Normal -> Very High
09/30/11 12:02reddogCharacteristic CodeReview Changed: "" -> "Needed"
09/30/11 12:02reddogStatusStatus Changed: Confirmed -> Resolved
09/30/11 12:02reddogAssignedAssigned to: "" -> "reddog"
09/30/11 12:02reddogResolutionResolution Changed: -> Fixed
09/30/11 12:02reddogFixed In: -> 3.8.0
06/20/14 10:24bc_adminCharacteristic Points Deleted: ""