It's Official: Lion gets the xTuple Stamp of Approval

 

jrogelstad's picture

The title says it all. We ran the xTuple client through our test battery on the lastest Apple operating system and it has passed with flying colors. As of today we officially support running our published xTuple 3.7.4 distribution on Macintosh Lion.*

*Note however, that PostgreSQL 9 that ships with Lion is not currently supported. xTuple 3.7.4 must connect to an 8.3 or 8.4 database. If you use the xTuple installer it will install an 8.4 PostgreSQL database. Support for PostgreSQL 9 is coming in xTuple 3.8.0 which is currently in beta.

 
kminx's picture
Offline
Joined: 10/21/2011
xTuple 3.7.4

When will xTuple 3.7.4 be available for download?

 
ptyler's picture
Offline
Joined: 12/10/2008
3.7.4

Hi, kminx:

3.7.4 is available for download. It doesn't have its own installer, but if you have 3.7.0 installed, you can easily upgrade to 3.7.4. See the PostBooks project page on SourceForge for the downloads:

http://sourceforge.net/projects/postbooks/

Regards,
Pierce

 
dkmeans's picture
Offline
Joined: 11/27/2007
The automatic installers all

The automatic installers all fail to actually completely install Postgresql on Lion at this time, including the EnterpriseDB versions that have served so well in the past.

 
jrogelstad's picture
Offline
Joined: 12/10/2008
There's some irony that

There's some irony that Apple's formal adoption of PostgreSQL into its operating system, which is something we should all look to as a great milestone in PostgreSQL's progress into mainstream technology, is actually creating difficulty for both us and the larger PostreSQL community.

I'm sure we'll bee looking at this issue closely as we finalize 3.8 and build the new installers for it.